Telco Software 'Mumble'
Info & Download

To use the conference software mumble you need a computer/laptop/notebook with microphone/speakers or an attached headset. Any computer with windows/linux/OSX younger than 6-5 years should do. Alternativly an iPhone or iPad (iOS 5.x) via WLAN or UMTS will work also.

1 2 3 downloadBackground

Download Mumble for iPhone / iPad V.1.1

starting Mumble on Vimeo.


Please connect using the following settings:

Important 1: You'll be asked if you accept a unverified certificate from my server. PLease do so. The certificate is only used for connection to telco.

Tip: When configuring the mumble software, i prefer using PUSH-TO-TALK with the "ctrl"-keystroke instead of the variant voice-induced (default).